1.8V VDDIO Level in XCORE-200

Technical discussions around xCORE processors (e.g. General Purpose (L/G), xCORE-USB, xCORE-Analog, xCORE-XA).
dcoryh192
New User
Posts: 2
Joined: Thu Jan 02, 2020 9:47 pm

1.8V VDDIO Level in XCORE-200

Postby dcoryh192 » Thu Jan 02, 2020 9:55 pm

Hi,

We are planning on using an XU208-128-QF48 in an upcoming project, and would benefit from being able to use 1.8V I/O levels due to another part with limited support for 3.3V. Is it possible to use 1.8V for VDDIO? There would still be 3V3 for everything else that needs it (USB_VDD33, OTP_VCC).

Thank you
User avatar
mon2
XCore Legend
Posts: 1849
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Fri Jan 03, 2020 2:06 pm

Hi. I will conclude as no. The datasheet does not list 1v8 as a viable value.

Best to remain at 3v3 and use bidirectional level translators to chat with devices that are strict 1v8 I/O swing. Texas Instruments features a good line of such devices.

As many translators are FET based, the pin drive strength is not very high so do not consider such a component for cable driving. Ok for short pcb trace driving to your target device.

Suggest to post the relevant part of the schematic before moving to a PCB layout when ready.

Hope this helps.
dcoryh192
New User
Posts: 2
Joined: Thu Jan 02, 2020 9:47 pm

Postby dcoryh192 » Fri Jan 03, 2020 8:20 pm

Thank you. Everything is PCB traces, so no drive strength worries though I appreciate the warning. Thankfully the XMOS has a minimal number of connections that I will need. I have other DSPs with the same issue that will cost much more to level shift. If they are able to work at 1V8 then I think I will be OK.
kevpatt
Member++
Posts: 23
Joined: Thu Feb 09, 2017 4:53 pm

Postby kevpatt » Thu Jan 30, 2020 9:13 pm

I've recently been thinking about the same question. I am considering using an xCORE-200 series device with an external PSRAM memory which operates at 1.8 VIO. I found the following quote in the xCORE-200-* datasheets:

"Separate I/O supplies are provided for the left, top, and right side of the package; different I/O voltages may be supplied on those."

This pretty clearly implies that the various I/O supplies may be different voltages, but does not give any clue as to how different, or what range of voltages would be usable. In the "Electrical Characteristics" section of the datasheet, the numbers "3.135, 3.30, 3.465" (min, typ, max) are shown for all VDDIO supplies. That's a pretty narrow range to be described as "different I/O voltages". I am therefore assuming that these numbers are simply the recommended ranges for when a 3.3 VDDIO is chosen, and may not necessarily imply that lower voltages could not be successfully used.

Under the "Absolute Maximum Ratings" section, the range "-0.3, 3.75" (min, max) is shown for VDDIO voltages. Thus, we can safely assume that voltages below 3.3 V will not harm the chip, but what the lowest working VDDIO voltage is perhaps still an open question.

Clearly the RGMII-capable ports can operate at 2.5 V. Perhaps the other VDDIO supplies can as well. Maybe they can even operate down to 1.8 V or lower. (I would image that voltages lower than the core voltage (1.0 V) would not work.) suppose the only way to know for sure is to design a board with separate VDDIO rails and test! I may do just that...
User avatar
akp
Respected Member
Posts: 466
Joined: Thu Nov 26, 2015 11:47 pm

Postby akp » Fri Jan 31, 2020 8:15 pm

It would be interesting to know. I think there's a theoretical problem that if the chip isn't necessarily guaranteed to work in whatever voltage you find it works at, that in the future you might get a perfectly functional specimen that doesn't work at the (out of spec) voltage you think it should. I doubt this is a likely scenario. But someone might not like it if you use the chip out of spec. Regardless you'll probably want to do more testing over temperature, etc if this is a product you'll be making multiples of.

I will say if you could use something like the XU216 (which is more expensive, obviously) then giving 1.8V to the VDDIOT (the one that can work at 2.5V) and using 3.3V (maybe?) for the rest might be safer... if it works.

Who is online

Users browsing this forum: No registered users and 3 guests