xCore 200 Software Reset

Technical discussions around xCORE processors (e.g. General Purpose (L/G), xCORE-USB, xCORE-Analog, xCORE-XA).
Posts: 10
Joined: Fri Apr 29, 2016 7:35 am

xCore 200 Software Reset

Postby Eliwood » Fri Apr 29, 2016 7:48 am


i tried the software reset on a self-made Xcore 200 board by writing to the PLL register, but the xcore doesn't boot from the flash. A Hardware reset with my reset button works fine :)

So i tried different sourcecodes...first reset on tile 1, then tile 0 , changed the order, using delays between the cores and so on, but the xcore never boot.

Is there another Software reset option? I can only do a manual reset, there is no option to do it with an output pin of the xcore.

Best regards
User avatar
XCore Addict
Posts: 185
Joined: Tue Mar 26, 2013 12:10 pm

Postby johned » Fri Apr 29, 2016 9:01 am


Have you tried this : http://www.xcore.com/forum/viewtopic.php?f=47&t=3539

Best regards,
Posts: 10
Joined: Fri Apr 29, 2016 7:35 am

Postby Eliwood » Fri Apr 29, 2016 9:20 am

yeah, i exactly tried this, and i tried different orders of the reset first t[0], then t[1] ....and t[1] and then t[0]. The Xcore is reacting on this code, but will not boot like i want.

Another phenomenon: Writing the sourcecode into the flash, starting from the flash -> xcore is not doing a soft reset
Experienced Member
Posts: 74
Joined: Mon Dec 16, 2013 12:14 pm

Postby colin » Fri Apr 29, 2016 10:25 am

On the 200 device you need to make sure bit 31 of the value written to the PLL register is cleared in order to obtain a soft reset.
Posts: 10
Joined: Fri Apr 29, 2016 7:35 am

Postby Eliwood » Fri Apr 29, 2016 11:55 am

unfortunately, it is not working too, same problem: he seems to do a restart but cant boot from the flash...i have no idea,
User avatar
XCore Legend
Posts: 1124
Joined: Thu May 27, 2010 10:08 am

Postby infiniteimprobability » Fri Apr 29, 2016 2:42 pm

It will be useful to understand the following to help diagnose further:

- Do you get any activity on the SPI lines when flash boot fails?
- Please attach a dumpstate of the processor

Code: Select all

xrun --dumpstate <yourfile.xe>
Respected Member
Posts: 346
Joined: Wed Jan 27, 2016 5:21 pm

Postby henk » Fri Apr 29, 2016 10:23 pm


Is it an external flash?


Who is online

Users browsing this forum: No registered users and 2 guests