MACBOOK USB C not detect audio device

Discussions about USB Audio on XMOS devices
mmar
Experienced Member
Posts: 105
Joined: Fri Jul 05, 2013 5:55 pm

MACBOOK USB C not detect audio device

Post by mmar »

We use cable USB C to USB B (tested more types and length) and found new issue on MACBOOK Air (Core2 and M1 tested).
Xmos usb audio device isnt detected if:

1. DAC USB B is connected first, MAC USB C is connected second Result no audio device. Ofcourse oposite order works ok.
2. XS1 U8 all lib xud tested v 2.3.2 2.4.1 2.6.1 same result (bus powered device)
3. XS2 XUF208 all tested but here only 2.6.1 have issue (self powered device)
4. XUF216 lib 2.6.1 no issue (self powered)

Any info appr...


mmar
Experienced Member
Posts: 105
Joined: Fri Jul 05, 2013 5:55 pm

Post by mmar »

FYI fixed with SELF POWERED define 0 1
User avatar
Ross
XCore Expert
Posts: 822
Joined: Thu Dec 10, 2009 9:20 pm
Location: Bristol, UK

Post by Ross »

Thanks for the update. SELF_POWERED will cause the xCORE to wait for vBus to be present before asserting it's pull up, this is important for compliance. For bus-powered devices this is not required since the xCORE is not on if there is no vBus... This setting just allows some BOM optimisations for bus-powered devices (don't have to wire up xCORE vBus and have to protect from bad vBus voltages etc).

Note, this is handle differently in xCORE.ai where a regular IO is used for vBUS detect with some external components (xCORE.ai USB phy doesn't have a vBUS comparator)
mmar
Experienced Member
Posts: 105
Joined: Fri Jul 05, 2013 5:55 pm

Post by mmar »

Thanks Ross, all this not explain why
1. DAC USB B is connected first, MAC USB C is connected second Result no audio device. Ofcourse oposite order works ok.