Hello && a timing analysis problem Topic is solved

New to XMOS and XCore? Get started here.
billaj
Junior Member
Posts: 5
Joined: Fri Mar 26, 2021 10:36 am

Hello && a timing analysis problem

Post by billaj »

Hi,i am new guy here ,i'd confused about the example AN00192. i download and build,that was successful, but ,when i double click on the binary "***.xe",the question come:
"Binary compiled without debug information.
Source annotations will not work.
enable Debugging (-g) for your project."
How can i fit this problem, thanks for answering !!!


View Solution
User avatar
CousinItt
Respected Member
Posts: 256
Joined: Wed May 31, 2017 6:55 pm

Post by CousinItt »

You are being prompted to add the -g option to the XCC_FLAGS options in the makefile for the project.

See the xTIMEcomposer documentation and AN00193 for using the debugger.
billaj
Junior Member
Posts: 5
Joined: Fri Mar 26, 2021 10:36 am

Post by billaj »

CousinItt wrote: Tue Jun 01, 2021 5:02 pm You are being prompted to add the -g option to the XCC_FLAGS options in the makefile for the project.

See the xTIMEcomposer documentation and AN00193 for using the debugger.

Thank you very much CousinItt. i will never know that should take the AN00193 first without you, thank you!!

By the way,AN00192 and AN00193, have not mention about "add the -g option to the XCC_FLAGS options in the makefile" in the documentation, i feel that not so friendly for new user.
User avatar
akp
XCore Expert
Posts: 544
Joined: Thu Nov 26, 2015 11:47 pm

Post by akp »

To be fair, it's not unusual for XMOS to be not so friendly for the new user.