xcc2clang.exe has stopped working

New to XMOS and XCore? Get started here.
ssmilo
Junior Member
Posts: 4
Joined: Thu Mar 29, 2018 8:04 pm

xcc2clang.exe has stopped working

Postby ssmilo » Tue Apr 03, 2018 4:33 pm

I started Community_14.3.2 (build 25550, Sep-30-2017), then it shows
the error message "xcc2clang.exe has stopped working". If I click
Close Program on the error message, then it just pops up again. See
the attachment for the message.

I loaded version 14.2.4 and the same thing happened.

Thank you for your help.

Image
robertxmos
XCore Addict
Posts: 169
Joined: Fri Oct 23, 2015 10:23 am

Postby robertxmos » Wed Apr 04, 2018 10:17 am

Hi ssmilo,

xcc2clang.exe is the C/C++ compiler (clang based!).
Are you compiling a project with C/C++ code when the error occurs?
Is there any output in the console?
Could you click 'Debug' to see if you can get more information.

Under normal operation xtimecomposer call xmake build systems, which calls xcc driver, which calls xcc2clang C- compiler.

Thank you
Robert
ssmilo
Junior Member
Posts: 4
Joined: Thu Mar 29, 2018 8:04 pm

Postby ssmilo » Thu Apr 05, 2018 3:04 pm

I start Community_14.3.2 or 14.2.4 and without doing anything else, the error occurs.
Sheldon
robertxmos
XCore Addict
Posts: 169
Joined: Fri Oct 23, 2015 10:23 am

Postby robertxmos » Thu Apr 05, 2018 4:18 pm

Hi Sheldon,
I am at a loss as to what is going on viz:
1. why/where/who is running xcc2clang.exe.
2. why it has stopped working.
Do you have a workspace? Are you loading a project?
(I can remove the xcc2clang.exe from the installation without any problems - as long as I don't try to build any C files).

Can you build a C projects from the command line?
download an example hellow world C programe and:
xcc -target=STARTKIT helloworld.c

Who is online

Users browsing this forum: No registered users and 4 guests