XE232-1024 Tile 3 RGMII Interface

New to XMOS and XCore? Get started here.
Junior Member
Posts: 4
Joined: Fri Jul 21, 2017 6:27 pm

XE232-1024 Tile 3 RGMII Interface

Postby davidk » Mon Oct 30, 2017 4:54 pm

XE232-1024-FB374 Tile 3 RGMII Issue

ISSUE: Can not seem to enable the RGMII TX interface.
Q1) What is the correct method/sequence to configure/enable the RGMII TX interface?
Currently acts as if the RGMII TX is not enabled.

Went through documentation and code examples and cannot seem to identify what is being over looked.
Code examples are for the XE216 on TILE 1 not TILE 3.
Standard hardware verification; power supplies within tolerance, same with Vripple, no XE232 to PHY PCB open or shorts and I/O signal mapping from XE232 to PHY.
XE232 controlled PHY reset timing and operation are as expected.
MDIO, MDC communication works between XE232 and TI PHY DP83867IRRGZT.
TI PHY DP83867IRRGZT auto negotiates with router and sends RX traffic to XE232.
Verified DP83867IRRGZT RX to XE 232 timing is as expected, running at 125MHZ.

20171031 Update:
Found default generated xn file enabled both USB ports. Once disabled USB gained some Ethernet control.
Verified received RX comm from PHY to RGMII are as expected.
Still cannot get RGMII TX to work.

20171107 Update:
Worked through the issues which bring this post to its conclusion.
Last edited by davidk on Tue Nov 07, 2017 1:03 pm, edited 1 time in total.
User avatar
XCore Legend
Posts: 1847
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Sat Nov 04, 2017 5:15 pm

Please post your xn file and schematics for the Ethernet section with xmos pin mapping for review. Also xmos code that maps the pins to ethernet hardware will be helpful.
Junior Member
Posts: 4
Joined: Fri Jul 21, 2017 6:27 pm

Postby davidk » Tue Nov 07, 2017 1:04 pm

Thank you for the offer to review. Worked through the issues and Ethernet is operational. This brings this post to a conclusion.
Posts: 16
Joined: Thu Jan 19, 2017 8:34 am

Postby Sanjeev » Wed Apr 17, 2019 11:32 am

Hello Davidk and Mon2,

I am facing the same issue. I have interfaced AR-8035 to XEF232 Tile 3; compilation is going on fine; Link LED's are blinking but I am not able to communicate with the XEF232 over RGMII; Not sure, where is the problem. Please find the snippet of xn file:

<Package id="0" Type="XS2-UEFnA-1024-FB374">
<Node Id="0" InPackageId="0" Type="XS2-L16A-512" SystemFrequency="500MHz" OscillatorSrc="1">
<Source Location="bootFlash0"/>
<Bootee NodeId="2"/>
<Tile Number="0" Reference="tile[0]">
<Port Location="XS1_PORT_1B" Name="PORT_SQI_CS_0"/>
<Port Location="XS1_PORT_1C" Name="PORT_SQI_SCLK_0"/>
<Port Location="XS1_PORT_4B" Name="PORT_SQI_SIO_0"/>
<Tile Number="1" Reference="tile[1]"/>
<Node Id="2" InPackageId="2" Type="XS2-L16A-512" SystemFrequency="500MHz" OscillatorSrc="3">
<Source Location="LINK" BootMode="4"/>
<Tile Number="0" Reference="tile[2]"/>
<Tile Number="1" Reference="tile[3]"/>
<Node Id="1" InPackageId="1" Type="periph:XS1-SU" Reference="usb_tile[0]" Oscillator="24MHz">
<Node Id="3" InPackageId="3" Type="periph:XS1-SU" Reference="usb_tile[1]" Oscillator="24MHz">
<Link Encoding="5wire" Delays="3clk">
<LinkEndpoint NodeId="0" Link="7"/>
<LinkEndpoint NodeId="2" Link="0"/>
<Link Encoding="5wire" Delays="3clk">
<LinkEndpoint NodeId="0" Link="4"/>
<LinkEndpoint NodeId="2" Link="3"/>
<Link Encoding="5wire" Delays="3clk">
<LinkEndpoint NodeId="0" Link="6"/>
<LinkEndpoint NodeId="2" Link="1"/>
<Link Encoding="5wire" Delays="3clk">
<LinkEndpoint NodeId="0" Link="5"/>
<LinkEndpoint NodeId="2" Link="2"/>
<Link Encoding="5wire">
<LinkEndpoint NodeId="0" Link="8" Delays="52clk,52clk"/>
<LinkEndpoint NodeId="1" Link="XL0" Delays="1clk,1clk"/>
<Link Encoding="5wire">
<LinkEndpoint NodeId="2" Link="8" Delays="52clk,52clk"/>
<LinkEndpoint NodeId="3" Link="XL0" Delays="1clk,1clk"/>

I am trying to communicate using UDP; Not sure, where the issue is. Can you guys helps me! Do I need to ulter the xn file?

Thanks in advance..
Posts: 1
Joined: Sun Aug 05, 2018 12:28 pm

Postby jgabbay » Sun Jul 14, 2019 2:13 pm


I am using XEF232-1024-FB374 , the "big brother" of the XCORE used on Explorer 200 board.

Trying to use both RGMII interface for TCP communication.

I encounter a funny phenomena,

where RGMII can receive Ethernet data at all rates (10 100 1000M - AUTO NEG) but can only transmit on 100M.

Furthermore, the link partner must be configured to 100M speed, or else the RGMII cannot transmit.

The PHY indicates the speed, and link state correctly, and it seems that something in eth.set_link_state() call is broken.
p_port_state in rgmii_buffering.xc is written, but for some reason, the process fails on 1000M.

Any idea? I wonder whether this MCU supports RGMII with 1000M?

The same code works fine on Explorer200 board.
Posts: 16
Joined: Thu Jan 19, 2017 8:34 am

Postby Sanjeev » Mon Aug 05, 2019 12:56 pm

XEF232-1024-FB374 supports 1000MBps; It works for me; Please use application 199 for further details to communicate using TCP.

Who is online

Users browsing this forum: No registered users and 1 guest