xtimecosmposer not working in ubuntu 20.04 Topic is solved

New to XMOS and XCore? Get started here.
suren_mj
New User
Posts: 2
Joined: Fri Jul 23, 2021 7:19 pm

xtimecosmposer not working in ubuntu 20.04

Post by suren_mj »

hello, i am new to linux and xtimecomposer. Trying to install xtimecomposer in ubuntu shows following issue. Dont have idea how to solve it.

(base) ra@sm:~/XMOS/xTIMEcomposer/Community_14.4.1$ xtimecomposer
OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.eclipse.osgi.internal.baseadaptor.BaseStorage (file:/home/surendra/XMOS/xTIMEcomposer/Community_14.4.1/xtimecomposer_bin/plugins/org.eclipse.osgi_3.9.1.v20140110-1610.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.internal.baseadaptor.BaseStorage
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
bash: line 1: 6114 Segmentation fault (core dumped) xtimecomposer.exe --launcher.appendVmargs -vmargs -Dcom.xmos.cdt.disableMozillaBrowserCreation=True -Dorg.eclipse.swt.browser.UseWebKitGTK=True


View Solution
User avatar
mon2
XCore Legend
Posts: 1910
Joined: Thu Jun 10, 2010 11:43 am

Post by mon2 »

suren_mj
New User
Posts: 2
Joined: Fri Jul 23, 2021 7:19 pm

Post by suren_mj »

Thanks @mon2 for the great help. Following the thread you linked, xtimecomposer is working now.