JTAG v14->v15 no longer works on v14

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
ClarkD
New User
Posts: 3
Joined: Mon Dec 13, 2021 8:50 pm

JTAG v14->v15 no longer works on v14

Post by ClarkD »

Hello;

We are on XUF216-512-TQ128-C20A, using a simplified version of the circular version of the audio dev board.

Everything we have done is on v14 of xTimeComposer. Yesterday one of our suppliers downloaded v15 and tried to flash the board with it.

Now the JTAG is seen under v15, but no longer under v14. We tried Windows and Linux, and both cannot see the JTAG board (with xrun -l) with v14, only the Windows v15 can see it. lsusb in Linux shows both the JTAG and the Board (two entries). Have we ruined our JTAG board? Is there a way to recover? THANKS


User avatar
TSC
Experienced Member
Posts: 111
Joined: Sun Mar 06, 2011 11:39 pm

Post by TSC »

This is probably due to a change in the XTAG driver which annoyingly breaks compatibility between v14 and v15 of the tools.

You should be able to get v14 tools to see the XTAG again by uninstalling the driver and reinstalling the older version.

More info here.