xTimeComposer on Ubuntu 20.04 Problem

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

xTimeComposer on Ubuntu 20.04 Problem

Postby bearcat » Thu Jun 04, 2020 1:34 am

Moving to Ubuntu 20.04 (Focal Fossa) from 18.04 (Bionic Beaver)

18.04: (must use jre 1.8, ok: need to delete libpangoft2-1.0.so.0, ok)
14.3.3 works fine
14.4.1 works fine

20.04: (tried both jre 1.8 and jre 1.11), (also needed: sudo apt-get install libcanberra-gtk-module)
14.3.3 java crash
14.4.1 java crash

Attached is crash report.
hs_err_pid5141.log
Ideas?
You do not have the required permissions to view the files attached to this post.
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Sat Jun 06, 2020 2:14 am

Made sure the problem was not my Ubuntu 20.04 build.

New install for 20.04 with only system updates applied.
sudo apt-get install libcanberra-gtk-module
sudo apt-get install openjdk-8-jre
sudo tar -xf ./xTIMEcomposer-Community_14-Linux64-Installer_Community_14.4.1.tgz -C /opt
cd /opt/XMOS/xTIMEcomposer/Community_14.4.1/scripts
sudo ./setup_xmos_devices.sh

xtimecomposer.sh:

Code: Select all

#!/bin/bash

cd /opt/XMOS/xTIMEcomposer/Community_14.4.1
source SetEnv
JAVA_HOME="/usr/lib/jvm/java-1.8.0-openjdk-amd64"
PATH=${JAVA_HOME}/bin:$PATH
xtimecomposer
Splash screen starts, then crashes.

I will keep my current computer for now to program, and move this to a VM in the future if needed.
I am good for now, hopefully this will get resolved.
magnus
Member
Posts: 10
Joined: Tue Aug 06, 2019 8:40 pm

Postby magnus » Wed Jun 17, 2020 4:53 pm

I have it running on 20.04. Granted it was a 19.10 -> 20.04 update if that matters.

My install notes, which I don't know if they are up to date or necessary also includes the following:
sudo apt install libtinfo5 libncurses5
Search XMOS folder for libpangoft2-1.0.so.0. Delete it.

My memory is very vague but I think there might have been another file that I needed to delete as well but my notes don't have anything about it. Sigh...
For what it is worth it is at least possible...
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Wed Jun 17, 2020 5:26 pm

Tried adding libtinfo5 libncurses5 pacakges on 20.04

still crash. I would think it is some dependency here.

Thanks for the reply.
synthcat
New User
Posts: 2
Joined: Wed Jun 24, 2020 7:27 pm

Postby synthcat » Wed Jun 24, 2020 7:30 pm

Howdy. I'm currently facing the exact same issue, and none of these steps have helped. Have you made any progress?

It would be great if xmos could fix this seeing as they're still recommending Ubuntu 14.04, which has been EoL for over a year!
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Mon Jun 29, 2020 8:33 pm

No updates. Still not working for me on 20.04.

Hopefully one of the team at XMOS upgrades to get this resolved.
synthcat
New User
Posts: 2
Joined: Wed Jun 24, 2020 7:27 pm

Postby synthcat » Mon Jun 29, 2020 9:30 pm

I was finally able to get this working - the answer is hiding over in this thread: viewtopic.php?f=26&t=6938

Basically you gotta do exactly what you did above installing it into /opt/, then delete or move both the ibpangoft2-1.0.so.0 as mentioned above, along with libpangocairo-1.0.so.0 It was deleting the second .so that I was missing.

And again, seems like a working installer for a non-obsolete GNU/Linux distro is long overdue from XMOS!
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Tue Jun 30, 2020 3:12 am

I was involved with the other tread also. Hmm... Didn't notice the newer reply.

So removing ibpangocairo-1.0.so.0 also is needed. xTimecomposer now starts.

But I am now having an error during build, though.
/opt/XMOS/xTIMEcomposer/Community_14.4.1/libexec/xcc2clang: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
See what I can work up on this one.
bearcat
Respected Member
Posts: 277
Joined: Fri Mar 19, 2010 4:49 am

Postby bearcat » Tue Jun 30, 2020 4:41 am

ok, appears 20.04 has moved up to libtinfo.so.6.

Install the legacy version:
sudo apt-get install libtinfo5

xTimecomposer now sucessfully builds my application. xFlash also successfully built my binary.

Looks solved.

Who is online

Users browsing this forum: No registered users and 1 guest