multiple_port input

Voice related projects and technical discussions
las
Newbie
Posts: 1
Joined: Mon Jun 26, 2017 2:59 am

multiple_port input

Postby las » Mon Jun 26, 2017 3:10 am

when I use the multiple port to input ,there is a problem that it is not ture as expect. Also, AN10129_xCORE_200_using_zip_unzip_with_multibit_ports cannot run ture.So,I want to know that,whether AN10129_xCORE_200_using_zip_unzip_with_multibit_ports has been checked true? I run it on the start kit ,but get the follow tips:
output data:
87654321
18765432
21876543
32187654

zipped output data:
03c5016a
0f35079a
2cc51e6a
8035489a

unzipped input data:
87654390
18765419
218765a1
3218762a
ERROR in input data 0. Expected 87654321, Received 87654390
ERROR in input data 1. Expected 18765432, Received 18765419
ERROR in input data 2. Expected 21876543, Received 218765a1
ERROR in input data 3. Expected 32187654, Received 3218762a
Loopback data check FAIL, 4 Errors

thank you !
User avatar
infiniteimprobability
XCore Legend
Posts: 1079
Joined: Thu May 27, 2010 10:08 am

Postby infiniteimprobability » Mon Jun 26, 2017 11:35 am

I'm surprised you got that far as startkit is XS-1 and doesn't support those instruction..

From the appnote:

xCORE-200 devices feature zip and unzip instructions, which facilitate the efficient use of multibit ports as multiple single bit ports.


You can still do the zip/unzip the old way using bit shifting and masking if needed?

Who is online

Users browsing this forum: No registered users and 2 guests