broken startKIT - first stage multi-node boot failed

All technical discussions and projects around startKIT
User avatar
Posts: 12
Joined: Thu Jan 04, 2018 8:34 pm

Re: broken startKIT - first stage multi-node boot failed

Postby uc69 » Sun Jan 07, 2018 11:21 pm

Thank you for your time.
The second_dump is 100% full of 0xff especially the start of the 262144 bytes file, so the erasing works. But I have more and more difficulties to get xflash working, it is now stalling in erasing for more than 15 minutes ! The 2 first erases worked and I could relaunch 3 times in a row a "run" in xTime without the pin 1 trick but now - again - i got the same problem on the fourth run trial and now erasing looks impossible, stalling forever !
So, I give up, I've just ordered a xCore-200 explorerkit in desperation and for not to stay on a failure with xmos.
...wonder how long it will take me till I screw it up !?
Thanks again for your time, I think there's nothing more we can do - exchange the spi flash ? I will try on my next Farnell order, it costs nothing but it seems that this ref. is also going obsolete !!
User avatar
Posts: 12
Joined: Thu Jan 04, 2018 8:34 pm

Postby uc69 » Sun Jan 07, 2018 11:27 pm

to be complete, xflash returned after more than 20 minutes trying to erase:

jea@4770K:/opt/XMOS/xTIMEcomposer/Community_14.3.2/bin$ ./xflash --verbose --erase-all --target-file STARTKIT.xn
XFlash_Options::ListDevices : xgdb --batch -q --ex listdevices devl-49e06aaa
xcc -w -Xmapper --dontenablesodlinks -Xmapper --nochaninit -Xmapper --noinitialtidy -Xmapper --bootstyle=forsim -x xn "STARTKIT.xn" -O2 -lflash -D xnPORT_SPI_MISO0=PORT_SPI_MISO -D xnPORT_SPI_SS0=PORT_SPI_SS -D xnPORT_SPI_CLK0=PORT_SPI_CLK -D xnPORT_SPI_MOSI0=PORT_SPI_MOSI -x xc "fe-986c112a" -o "fe-20d4816f"
XFlash_Utils::BuildRunCommand : xrun --io fe-20d4816f
xrun: Program received signal ET_ILLEGAL_RESOURCE, Resource exception.
[Switching to tile[0] core[3]]
0x00010a64 in fl_int_spiInit ()

Error: F03013 Failed to run : 0x7ffeeb580870.
User avatar
XCore Legend
Posts: 1889
Joined: Thu Jun 10, 2010 11:43 am

Postby mon2 » Sun Jan 07, 2018 11:28 pm

Yup, feel your pain. My startkit on this box is somewhat stable but once in a while the toolchain will report that another process is control. Do not believe it is the virus protection tools but not sure.

If the flash is blank then you should be ok but replace and see. According to ISSI (US factory), their FAE is reporting they have ample stock of the older flash version. However, the new version is faster and lower cost but then there is the pain of XMOS compatibility due to flash ID checks. There is another very long thread on this forum regarding that issue and the XHRA audio processor. Summary, the OTP rom code is looking for a limited set of flash IDs (each of the supported flash is now on the EOL list) and if the IDs mismatch, the encrypted code goes bezerk.

We tried..

Who is online

Users browsing this forum: No registered users and 1 guest