XCORE-200 MC audio - initial firmware lost Topic is solved

New to XMOS and XCore? Get started here.
Posts: 9
Joined: Tue Feb 04, 2020 1:33 pm

XCORE-200 MC audio - initial firmware lost

Postby troldenstein » Tue Feb 04, 2020 2:08 pm

Hello guys,

Today development kit arrived to me and I begun experimenting with it and successfully uploaded led blinking example to it using on board led matrice.
Now I realized that I did not experiment with the firmware that was already in the kit when it arrived and not sure how it was working. I had time to see that "TUSBaudio control panel" detected the device and reported 10 output channels.

Is there a way to restore that firmware (binary available) or is one of the examples provided in (https://www.xmos.com/software/usb-audio) "USB Audio 2.0 software" supposed to be one of those?
I found that project name "app_usb_aud_xk_216_mc" has 4 audio channels out and 4 channels in and "TUSBaudio control panel" does not recognize it, so it does not satisfy me :D

Similar topic: (viewtopic.php?t=6048)

Binaries would be enough for me just to test/experiment the kit ':D
View Solution
Posts: 9
Joined: Tue Feb 04, 2020 1:33 pm

Postby troldenstein » Thu Feb 06, 2020 8:25 am

Solved (to those who struggle with same case):

Main notice! USB audio card was detected as usb 1.0!

app_usb_aud_xk_216_mc is actually correct project, can be called as reference design (when using setup 2i10o10xxxxxx the device will have 10 outs and ins and usb 2.0 device)..

My issue was solved through understanding how to use the xtime composer and selection of project settings:
project->properties->build configurations (select configuration as active) effect is written in makefile
then what I missed:
flash button on top (lightning) select binary that was built previously to new flashing configuration and flash it..
to make my board to work I had to reboot win10 pc once and then everything worked nicely :P

Hope this helps someone :)

Who is online

Users browsing this forum: etori90 and 0 guests