xCORE ARRAY MICROPHONE details

New to XMOS and XCore? Get started here.
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

xCORE ARRAY MICROPHONE details

Postby bhanuprakashbv » Fri Oct 06, 2017 3:51 am

Hi,

What are all drivers I have to install to connect board "XP-USB-MIC-UF216" to PC.
Any firmware is required?

Could you please explain me details about the process.
Along with detailed process, share the paths for software so that I can install the software which you are pointing to.

I have installed TUSB Control Panel, xTIME composer.

When I connected board to PC, TUSB Control panel was showing "No Devices Found".
How to resolve that?

My first experiment would be, Connect Board to PC and record mic's audio using Audacity.
Please help me to resolve issues.

Thanks,
Bhanu
User avatar
johned
Experienced Member
Posts: 123
Joined: Tue Mar 26, 2013 12:10 pm
Contact:

Postby johned » Fri Oct 06, 2017 9:12 am

Hi Bhanu,

All of the firmware and documentation is available here : https://www.xmos.com/support/boards?product=20258.
You basically need to download "USB Audio 2.0 Device Software - source code" and build it in xTIMEcomposer.
If you are only using UAC1 then you do not require the Thesycon driver, this is only required for UAC2.

Best regards,
John
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

Postby bhanuprakashbv » Fri Oct 06, 2017 11:23 pm

Hi John,

I have downloaded USB Audio 2.0 Device Software - source code. Tried to built with xTIMEcomposer (Selected downloaded folder using options => File->Import->General->Existing Projects into Workspace). Is it OK to select like this?

I ran Build all command. It went fine with some warnings. <11:50:42 Build Finished (took 582ms)>

If above two steps are correct, Let me know what to do next. ( What and where to copy and how to load to board? )
If incorrect, Let me know correct procedure.

May be I am asking simple questions, I am very new to this development board.

Thanks,
Bhanu
User avatar
johned
Experienced Member
Posts: 123
Joined: Tue Mar 26, 2013 12:10 pm
Contact:

Postby johned » Sat Oct 07, 2017 9:14 am

Hi Bhanu,
Yes, this is correct.
Now you need to flash the board. You can do this from either the context menu or the flash button on the button bar.
This might help : https://www.xmos.com/news/videos/17694

Best,
John
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

Postby bhanuprakashbv » Mon Oct 09, 2017 7:32 pm

Hi John,

Thank you John. I have watched the video provided by you. I followed steps which they mentioned in that video.

When I opened project using xTIME Composer, Found there are two targets available :
1i8o2 and 2i8o2. How can I see details about targets? I built for 2i8o2 but want to know what is this target and other target also.

Build was successful, I could find "app_usb_aud_mic_array_2i8o2.xe". Is this the sample application from XMOS for board "XP-USB-MIC-UF216" ???
As I mentioned earlier, My first experiment would be, Connect Board to PC and record mic's audio using Audacity. Is "app_usb_aud_mic_array_2i8o2.xe" solves my issue?

If YES, How to flash "app_usb_aud_mic_array_2i8o2.xe" to board? Could you please guide me to do this.
If NO, Let me know what application to build.

Thanks,
Bhanu
User avatar
johned
Experienced Member
Posts: 123
Joined: Tue Mar 26, 2013 12:10 pm
Contact:

Postby johned » Mon Oct 09, 2017 9:59 pm

Hi Bhanu,

The first number '1' or '2' refers to the USB audio class. Under Windows UAC1 is supported natively and UAC2 requires a driver in all but the latest Windows 10 update.

For full details of the specific build configurations, please refer to the USB audio design guide : https://www.xmos.com/download/private/s ... ha1%29.pdf

You will need to flash the board using the flash button on the button bar as I mentioned earlier.

Best regards,
John
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

Postby bhanuprakashbv » Mon Oct 09, 2017 10:59 pm

Hi John,

I have built for 2i8o2 target. Observer below warnings:
at start:
Warning: F03098 Factory image and boot loader cannot be write-protected on flash device on node 0
xflash: Warning: F03148 --quad-spi-clock not given, using default 15.62MHz
xflash: Warning: F03149 QE_REGISTER and/or QE_BIT locations not found in XN file for this flash device. Using default quad_spi_qe_location_status_reg_0 and quad_spi_qe_bit_6.

at end:
Site 0 has finished successfully.

I have flashed "app_usb_aud_mic_array_2i8o2.xe" to board using flash button.
Still board is not detected. TUSBAudio Control panel shows "No devices connected".

I think, Currently I ma building for generic. How can I build for target : XP-USB-MIC-UF216 board?
How to change target during build?


Thanks,
Bhanu

Image
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

Postby bhanuprakashbv » Tue Oct 10, 2017 12:46 am

Hi John,

For XCORE MICROPHONE ARRAY Board (XP-USB-MIC-UF216)?
Currently I am building "app_usb_aud_mic_array" module and target as "2i8o2" but not wroking (board is not detected as USB audio device).

Which application I have to build in xTIME Composer?
Which target I have to use to build?

Is *.xe flashing via jtag enough to detect multi-mic array board in PC?

Thanks,
Bhanu
bhanuprakashbv
Member++
Posts: 20
Joined: Wed Sep 06, 2017 10:13 pm

Postby bhanuprakashbv » Tue Oct 10, 2017 3:34 am

If possible, Could you please share .xe file for flashing the XCORE MICROPHONE ARRAY Board (XP-USB-MIC-UF216).
puzzle
New User
Posts: 3
Joined: Thu Oct 05, 2017 10:26 pm

Postby puzzle » Tue Oct 10, 2017 5:44 pm

I've the same issue and also noticed there're some other users asking about it.

Return to “Getting started”

Who is online

Users browsing this forum: No registered users and 9 guests