libxud_u compilation problems

Technical questions regarding the xTIMEcomposer, xSOFTip Explorer and Programming with XMOS.
GerhardNorkus
Active Member
Posts: 55
Joined: Wed Jan 05, 2011 2:15 pm

libxud_u compilation problems

Postby GerhardNorkus » Thu Oct 17, 2013 7:58 pm

Hi All,

Problems with sc_usb_device (1.0.1).

I downloaded, and there were a bunch of changes with the libxud library. Name changes weren't a problem, but when I compile, I always get the following message -

XUDManager.xc - undefined reference to usb_tile

usb_tile is defined in the .xn file. Previously, it had 'core' in front of it. Now it has 'tileref'. In any case, I cannot compile with the new module.

By the way. I am not using the standard method of importing modules. I simply copy the xud and usb directories into my own project. I then copy the libxud_u.a into the targets\lib directory of the xTIMEcomposer directory in c:\program files (x86)\XMOS directory in windows. I then add the following to my xcc flags: -lxud_u. This worked for libxud_s.

There was also a problem with two of the inlines in the xud.h file. XUD_SetReady_Out and XUD_SetReady_In get thrown as undefined inlines during the compile in this new version. Can anyone at XMOS look at this???

Thanks!
User avatar
sethu_jangala
XCore Expert
Posts: 589
Joined: Wed Feb 29, 2012 10:03 am

Postby sethu_jangala » Mon Oct 21, 2013 10:22 am

Which version of Tool are you using? You should use 12.2.0 for building XUD. You might not be able to build XUD module with 13 version of Tool.

Sethu.
GerhardNorkus
Active Member
Posts: 55
Joined: Wed Jan 05, 2011 2:15 pm

Postby GerhardNorkus » Fri Oct 25, 2013 4:09 am

12.2.0
User avatar
Ross
XCore Expert
Posts: 768
Joined: Thu Dec 10, 2009 9:20 pm

Postby Ross » Fri Oct 25, 2013 10:34 am

What exactly are you trying to build please? I just download sc_usb_device.zip from xmos.com and can build the HID mouse example okay.
maqu67
Member++
Posts: 22
Joined: Tue Jan 23, 2018 3:26 pm

Postby maqu67 » Thu May 21, 2020 6:16 pm

Hello,

I'm trying to modify the "sw_usb_audio-[sw]_6.15.2" software because I don't need some features.
I've compilation problems with "module_xud" .

I builded a new project starting from zero and I'm trying to add audio usb2.0 feature.
I imported the "module_xud" in the new project from the original software directory and I try to compile the new solution I've
the following error:

Failed to find library "libxud_u.a"

....
Compiling spline_coeff_gen_inner_loop_asm.S
Compiling swlock_asm.S
Compiling SpdifReceive.S
Compiling lock.S
Compiling XUD_EpFuncs.S
Rebuild .build/_obj.rsp
Creating AudioBoard-xCore-200-v01.xe
xmap: Error: Failed to find library "libxud_u.a".
xmake[1]: *** [bin//AudioBoard-xCore-200-v01.xe] Error 1
xmake: *** [bin//AudioBoard-xCore-200-v01.xe] Error 2

19:01:50 Build Finished (took 48s.457ms)

I've just added the path : module_xud/lib/xs1b

can you help me?

Best Regards

Massimiliano

Who is online

Users browsing this forum: No registered users and 0 guests